Willkommen, Gast!

Wenn dies Ihr erster Besuch in unserem Forum ist, sollten Sie sich zuerst unsere Forum-Netiquette durchlesen. Bevor Sie nun Beiträge schreiben, empfehlen wir Ihnen eine kostenlose Registrierung, da Sie durch Ihren eigenen Account deutlich mehr Features und Komfort im Forum genießen können. Wenn Sie ein bestimmtes Thema suchen, können Sie unsere Suchfunktion benutzen. Falls Sie sich bereits angemeldet haben, können Sie Ihren Account (im Menü links unter Mein Profil aufrufbar) verwalten.


Neue Beiträge, der letzten 24 Stunden
.


Es ist jetzt 20:23 Uhr.

Hardware-Mag - Forum » Hardware » Netzwerk & Internet » Router + IIS5.1
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Neues Thema erstellen Antwort erstellen
Router + IIS5.1
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
nordi
Hardware-Noob


images/avatars/avatar-339.gif

Dabei seit: 03.01.2006
Beiträge: 4
Herkunft: Wien

Router + IIS5.1 Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Ich habe Win XP Prof. Edition mit dem inkludierten IIS5.1 installiert. Ursprünglich hatte ich keinen Router und ich konnte meine lokalen Seiten am PC via IIS5.1 aufrufen. Ich hatte in der LAN-Karte bei TCP-IP jeweils dynamisch bei den IP-Adressen und bei DNS eingestellt.

Seitdem 3 PCs im Lan via Router hängen und ich via Router auch ins Internet gehe, sind auf dem PC die IP-Adresse samt Standard-Gateway eingetragen und die DNS-Server. Jetzt findet er die lokalen Seiten nicht mehr, obwohl sie im IIS5.1 ersichtlich sind.

Muss eine zusätzliche Gateway-Seite eingetragen werden? Wie bringe ich ihn dazu, nicht nur zum Router zu schauen?

03.01.2006 09:15 E-Mail an nordi senden Homepage von nordi Beiträge von nordi suchen
ventu
Hardware-Gott


images/avatars/avatar-472.png

Dabei seit: 24.12.2005
Beiträge: 3.096
Herkunft: Rheinland-Pfalz

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Hi,

Du musst eine Weiterleitung vom Router zu dem PC in deinem lokalen Netzwerk einrichten, der die Seite hostet.
Schau mal nach einem Eintrag --> Port Forwarding, meistens zu finden unter --> NAT



__________________
[Laptop] Thinkpad X300 | Ubuntu 11.04 Natty
[Server] VMware ESXi 5.0 | Supermicro X8SIL-F | Intel Xeon X3440 | 16GB Mushkin Proline PC3-10667E ECC | 2x3TB Seagate Constellation ES.2 SAS @ zfs_mirror | LSI SAS 9211-4i
03.01.2006 12:41 E-Mail an ventu senden Beiträge von ventu suchen
nordi
Hardware-Noob


images/avatars/avatar-339.gif

Dabei seit: 03.01.2006
Beiträge: 4
Herkunft: Wien

Themenstarter Thema begonnen von nordi
Port-Forwarding Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Ich habe einen Zyxel Prestige und bin was Netzwerk betrifft, ziemlicher Anfänger.

Ich hab unter LAN DHCP-Server angekreuzt und unter DNS-Server "user-defined" ausgewählt und die IP-Adresse meines PCs eingetragen, auf dem sich die lokale Seite und IIS befindet. Sonst gibt es noch IP-Alias einzutragen, was ich nicht gemacht habe.

Hat das was mit RIP-Weiterleitung zu tun?

Unter SUA/NAT gibt es SUA-Server mit Standard-Server mit 11 Zeilen für Name, Start-Port, End-Port, Server-IP-Adresse, bei Adressumsetzung Lokale Start-IP, Lokale End-IP, Globale Start-IP, Globale End-IP und Typ (insges. 10 Zeilen), bei Auslösender Port Name, Eingehend Start-Port und End-Port, Auslösend Start- und End-Port.

03.01.2006 16:33 E-Mail an nordi senden Homepage von nordi Beiträge von nordi suchen
ventu
Hardware-Gott


images/avatars/avatar-472.png

Dabei seit: 24.12.2005
Beiträge: 3.096
Herkunft: Rheinland-Pfalz

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Du brauchst keinen DNS-Server zu definieren - es sei denn, Du willst die Seite auch außerhalb Deines Netzwerks zugänglich machen.


Der Eintrag befindet sich im Menü NAT. Allerdings kann ich so mit den von Dir vorgegebenen Werten wenig anfangen. Schau mal im Handbuch nach (falls vorhanden) ob Du irgendwas wie Portforwarding/Weiterleitung finden kannst.

Ansonsten probier einfach ein paar Einträge. Adressumsetzung bzw. Start/End-Port scheint mir recht vielversprechend zu sein.

Du musst da dann die interne IP von dem Host-Rechner eintragen und den lokalen Port, unter dem IIS bei diesem Computer läuft.
Über den Browser lässt sich der lokale Websever dann aufrufen mit dem Befehl:
http://interne ip vom host:port (falls ungleich 80)



__________________
[Laptop] Thinkpad X300 | Ubuntu 11.04 Natty
[Server] VMware ESXi 5.0 | Supermicro X8SIL-F | Intel Xeon X3440 | 16GB Mushkin Proline PC3-10667E ECC | 2x3TB Seagate Constellation ES.2 SAS @ zfs_mirror | LSI SAS 9211-4i
03.01.2006 18:58 E-Mail an ventu senden Beiträge von ventu suchen
nordi
Hardware-Noob


images/avatars/avatar-339.gif

Dabei seit: 03.01.2006
Beiträge: 4
Herkunft: Wien

Themenstarter Thema begonnen von nordi
Einträge Zyxel-Router Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Portforwarding habe ich in meiner Doku nicht gefunden. Lt. Hilfe sind die Einträge in NAT dazu da, Anfragen von aussen, welche z. B. über Port 80 kommen an den Rechner, auf welchem i. d. Fall IIS läuft, zu ermöglichen. Ich möchte jedoch von aussen keine Zugriffe auf den IIS haben, nicht einmal innerhalb des LANs, sondern für Testzwecke soll vom gleichen Rechner, auf welchem der IIS läuft abgefragt werden. Nicht mehr.

05.01.2006 17:39 E-Mail an nordi senden Homepage von nordi Beiträge von nordi suchen
nordi
Hardware-Noob


images/avatars/avatar-339.gif

Dabei seit: 03.01.2006
Beiträge: 4
Herkunft: Wien

Themenstarter Thema begonnen von nordi
andere IP-Adresse Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Ein Eintrag im Router hat sich erübrigt. Die IP-Adresse der Standard-Webpage war auf 192.1.168.33 (oder 34 ?). Ich habe sie auf 192.1.168.10 geändert, die gleiche, auf die mein PC läuft. Damit findet er die Seiten.

Wie das funktionieren soll, wenn man mehrere Webpages mit unterschiedlichen IP-Adressen im IIS einrichtet, ist mir zwar unklar, brauch ich derzeit aber nicht.

12.01.2006 11:39 E-Mail an nordi senden Homepage von nordi Beiträge von nordi suchen
Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
Hardware-Mag - Forum » Hardware » Netzwerk & Internet » Router + IIS5.1



Forensoftware: Burning Board 2.3.6, entwickelt von WoltLab GmbH