Willkommen, Gast!

Wenn dies Ihr erster Besuch in unserem Forum ist, sollten Sie sich zuerst unsere Forum-Netiquette durchlesen. Bevor Sie nun Beiträge schreiben, empfehlen wir Ihnen eine kostenlose Registrierung, da Sie durch Ihren eigenen Account deutlich mehr Features und Komfort im Forum genießen können. Wenn Sie ein bestimmtes Thema suchen, können Sie unsere Suchfunktion benutzen. Falls Sie sich bereits angemeldet haben, können Sie Ihren Account (im Menü links unter Mein Profil aufrufbar) verwalten.


Neue Beiträge, der letzten 24 Stunden
.


Es ist jetzt 04:57 Uhr.

Hardware-Mag - Forum » Software » Programmieren » HTML Hilfe: Weiterleitung zur Startseite
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Neues Thema erstellen Thema ist geschlossen
HTML Hilfe: Weiterleitung zur Startseite
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
monster23 monster23 ist männlich
High-End-User


images/avatars/avatar-70.jpg

Dabei seit: 24.12.2005
Beiträge: 566
Herkunft: Österreich

HTML Hilfe: Weiterleitung zur Startseite Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Wenn jetzt im Internet meine Homepage findet z.b mit einer Unterkategorie wie z.b ...../.....html, wie schaffe ich es das er zuerst auf die Hauptpage gehn muss



__________________
My Systems Intel i5 - 2500K, 8GB Geil Corsa 1600 CL9, Mainboard: MSI P67A C45, Kühlung: Alpenföhn Brocken mit einem Gelid Extreme 120 Lüfter, Festplatte: Crucial C300 128GB SSD zweitplatte ist eine Western Ditigal Green 2 TB, Grafikkarte: derzeit Asus 560Ti Dircet CU, Gehäuse Thermaltake V9
29.01.2006 02:01 E-Mail an monster23 senden Beiträge von monster23 suchen
Deeival Deeival ist männlich
HwM-Idol


images/avatars/avatar-25.jpg

Dabei seit: 24.12.2005
Beiträge: 1.078
Herkunft: Canada

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Du koenntest mir Php/Javascript auf der Hauptseite nen Cookie setzen, und auf den Unterseiten kontrollieren.
Oder du checkst auf den Unterseiten die Referenz (? - die URL wo man auf den Link geklickt hat).


Vielleicht gehts auch anders Augenzwinkern

29.01.2006 02:47 E-Mail an Deeival senden Homepage von Deeival Beiträge von Deeival suchen Fügen Sie Deeival in Ihre Kontaktliste ein
monster23 monster23 ist männlich
High-End-User


images/avatars/avatar-70.jpg

Dabei seit: 24.12.2005
Beiträge: 566
Herkunft: Österreich

Themenstarter Thema begonnen von monster23
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Leider kann ich noch kein Php oder Java, somit fällt das komplet ins Wasser. Ich bin ja auch grad erst dabei XML und CSS zu lernen



__________________
My Systems Intel i5 - 2500K, 8GB Geil Corsa 1600 CL9, Mainboard: MSI P67A C45, Kühlung: Alpenföhn Brocken mit einem Gelid Extreme 120 Lüfter, Festplatte: Crucial C300 128GB SSD zweitplatte ist eine Western Ditigal Green 2 TB, Grafikkarte: derzeit Asus 560Ti Dircet CU, Gehäuse Thermaltake V9
29.01.2006 09:55 E-Mail an monster23 senden Beiträge von monster23 suchen
ventu
Hardware-Gott


images/avatars/avatar-472.png

Dabei seit: 24.12.2005
Beiträge: 3.096
Herkunft: Rheinland-Pfalz

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Das lässt sich ganz einfach mit php realisieren. Dazu muss man sich damit nicht mal damit besonders gut auskennen.

Angenommen, jemand besucht Deine Hauptseite. Er klickt dann weiterhin auf einen Link, der ihn zu .../...html führt. Ihm wird dann automatisch ein Argument mit übergeben. Z.b.

unterseite.php?session=valid

(Das die Seite *.php anstatt *.html heißt, macht in dem Fall nicht viel aus.)

Auf der Unterseite wird dann die Variable geprüft mit if($session). Ist sie vorhanden, war der Besucher eben auf der Hauptseite und die Unterseite ist angezeigt. Ist sie nicht vorhanden, wird eine Weiterleitung auf die Hauptseite aktiviert. Ich (oder jemand anders hier) kann Dir später mal ein Beispiel posten. Ist wirklich minimaler Aufwand smile



__________________
[Laptop] Thinkpad X300 | Ubuntu 11.04 Natty
[Server] VMware ESXi 5.0 | Supermicro X8SIL-F | Intel Xeon X3440 | 16GB Mushkin Proline PC3-10667E ECC | 2x3TB Seagate Constellation ES.2 SAS @ zfs_mirror | LSI SAS 9211-4i
29.01.2006 13:51 E-Mail an ventu senden Beiträge von ventu suchen
monster23 monster23 ist männlich
High-End-User


images/avatars/avatar-70.jpg

Dabei seit: 24.12.2005
Beiträge: 566
Herkunft: Österreich

Themenstarter Thema begonnen von monster23
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

das wäre echt super, danke



__________________
My Systems Intel i5 - 2500K, 8GB Geil Corsa 1600 CL9, Mainboard: MSI P67A C45, Kühlung: Alpenföhn Brocken mit einem Gelid Extreme 120 Lüfter, Festplatte: Crucial C300 128GB SSD zweitplatte ist eine Western Ditigal Green 2 TB, Grafikkarte: derzeit Asus 560Ti Dircet CU, Gehäuse Thermaltake V9
29.01.2006 17:19 E-Mail an monster23 senden Beiträge von monster23 suchen
Deeival Deeival ist männlich
HwM-Idol


images/avatars/avatar-25.jpg

Dabei seit: 24.12.2005
Beiträge: 1.078
Herkunft: Canada

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Zitat:
Original von ventuklotz
unterseite.php?session=valid

(Das die Seite *.php anstatt *.html heißt, macht in dem Fall nicht viel aus.)


Dann kann man aber die Unterseiten in die Bookmarks speichen, und bekommt das ?session=valid mit Augenzwinkern

php:
1:
2:
3:
if ($_GET[session]) != valid) {
      headers("Location: ../index.html");
}


wobei das ../index.html die Andresse von der Hauptseite ist.

Beachte, dass das ganze vor dem </head> Tag passieren muss!

Edit 1,2 und 3: Man kann den Code leider nicht groesser machen - kann ja keiner lesen so wies im moment ist.
Und der Preview Knopf ist immernoch nicht da Augenzwinkern

Dieser Beitrag wurde 3 mal editiert, zum letzten Mal von Deeival: 29.01.2006 19:06.

29.01.2006 19:04 E-Mail an Deeival senden Homepage von Deeival Beiträge von Deeival suchen Fügen Sie Deeival in Ihre Kontaktliste ein
Babe Babe ist männlich
Redakteur


images/avatars/avatar-450.gif

Dabei seit: 24.12.2005
Beiträge: 7.977
Herkunft: BW

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Also wenn ich das richtig verstehe, willst du einfach, dass jeder Besucher deiner Seite zuerst auf die Startseite weitergeleitet wird?

Würde ich nicht via Cookie machen, da viele User auch Cookies deaktiviert haben und das ganze dann nicht funktioniert. Du könntest mit PHP auch die URL in der Adressleiste abfragen lassen... wenn du keine Frames benutzt, funktioniert das einwandfrei...



__________________
Mein System: ZOTAC ZBOX EI750 Plus, Intel Core i7-4770R, 8 GB DDR3-1333, OCZ Vector 150 (480 GB), Windows 8.1 Pro 64 Bit, 2x Samsung SyncMaster 2494HM, A4Tech Bloody B540 und A4Tech Bloody RT5A.
29.01.2006 19:11 E-Mail an Babe senden Homepage von Babe Beiträge von Babe suchen
monster23 monster23 ist männlich
High-End-User


images/avatars/avatar-70.jpg

Dabei seit: 24.12.2005
Beiträge: 566
Herkunft: Österreich

Themenstarter Thema begonnen von monster23
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Wie geht das



__________________
My Systems Intel i5 - 2500K, 8GB Geil Corsa 1600 CL9, Mainboard: MSI P67A C45, Kühlung: Alpenföhn Brocken mit einem Gelid Extreme 120 Lüfter, Festplatte: Crucial C300 128GB SSD zweitplatte ist eine Western Ditigal Green 2 TB, Grafikkarte: derzeit Asus 560Ti Dircet CU, Gehäuse Thermaltake V9

Dieser Beitrag wurde 2 mal editiert, zum letzten Mal von monster23: 30.01.2006 00:16.

29.01.2006 20:15 E-Mail an monster23 senden Beiträge von monster23 suchen
Babe Babe ist männlich
Redakteur


images/avatars/avatar-450.gif

Dabei seit: 24.12.2005
Beiträge: 7.977
Herkunft: BW

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

php:
1:
http://$_SERVER[SERVER_NAME]$_SERVER[REQUEST_URI]
Das gibt dir zB die aktuelle URL an... die kannst du dann ja weiter verarbeiten... zB mit ereg() oder ähnlichem smile



__________________
Mein System: ZOTAC ZBOX EI750 Plus, Intel Core i7-4770R, 8 GB DDR3-1333, OCZ Vector 150 (480 GB), Windows 8.1 Pro 64 Bit, 2x Samsung SyncMaster 2494HM, A4Tech Bloody B540 und A4Tech Bloody RT5A.
30.01.2006 02:39 E-Mail an Babe senden Homepage von Babe Beiträge von Babe suchen
ventu
Hardware-Gott


images/avatars/avatar-472.png

Dabei seit: 24.12.2005
Beiträge: 3.096
Herkunft: Rheinland-Pfalz

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

er benutzt aber frames ....



__________________
[Laptop] Thinkpad X300 | Ubuntu 11.04 Natty
[Server] VMware ESXi 5.0 | Supermicro X8SIL-F | Intel Xeon X3440 | 16GB Mushkin Proline PC3-10667E ECC | 2x3TB Seagate Constellation ES.2 SAS @ zfs_mirror | LSI SAS 9211-4i
30.01.2006 09:55 E-Mail an ventu senden Beiträge von ventu suchen
Babe Babe ist männlich
Redakteur


images/avatars/avatar-450.gif

Dabei seit: 24.12.2005
Beiträge: 7.977
Herkunft: BW

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Zitat:
Original von ventuklotz
er benutzt aber frames ....

Dann geht das so natürlich nicht smile

Alternativ zu Cookie könnte man noch Session vorschlagen, aber ob der Aufwand für sowas lohnt? Erzähl doch mal mehr über dien Projekt smile



__________________
Mein System: ZOTAC ZBOX EI750 Plus, Intel Core i7-4770R, 8 GB DDR3-1333, OCZ Vector 150 (480 GB), Windows 8.1 Pro 64 Bit, 2x Samsung SyncMaster 2494HM, A4Tech Bloody B540 und A4Tech Bloody RT5A.
31.01.2006 00:04 E-Mail an Babe senden Homepage von Babe Beiträge von Babe suchen
monster23 monster23 ist männlich
High-End-User


images/avatars/avatar-70.jpg

Dabei seit: 24.12.2005
Beiträge: 566
Herkunft: Österreich

Themenstarter Thema begonnen von monster23
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Das lohnt sich dann doch net. Werd in einem halben Jahr dann mit PHP anfangen, bis dahin wird das dann schon noch reichen grinsen



__________________
My Systems Intel i5 - 2500K, 8GB Geil Corsa 1600 CL9, Mainboard: MSI P67A C45, Kühlung: Alpenföhn Brocken mit einem Gelid Extreme 120 Lüfter, Festplatte: Crucial C300 128GB SSD zweitplatte ist eine Western Ditigal Green 2 TB, Grafikkarte: derzeit Asus 560Ti Dircet CU, Gehäuse Thermaltake V9
31.01.2006 01:14 E-Mail an monster23 senden Beiträge von monster23 suchen
monster23 monster23 ist männlich
High-End-User


images/avatars/avatar-70.jpg

Dabei seit: 24.12.2005
Beiträge: 566
Herkunft: Österreich

Themenstarter Thema begonnen von monster23
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden

Danke für eure Hilfe. War zwar nix dabei was ich brauchen kann, is aber net so schlimm. grinsen



Thread kann geschlossen werden



__________________
My Systems Intel i5 - 2500K, 8GB Geil Corsa 1600 CL9, Mainboard: MSI P67A C45, Kühlung: Alpenföhn Brocken mit einem Gelid Extreme 120 Lüfter, Festplatte: Crucial C300 128GB SSD zweitplatte ist eine Western Ditigal Green 2 TB, Grafikkarte: derzeit Asus 560Ti Dircet CU, Gehäuse Thermaltake V9
31.01.2006 19:50 E-Mail an monster23 senden Beiträge von monster23 suchen
Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Thema ist geschlossen
Hardware-Mag - Forum » Software » Programmieren » HTML Hilfe: Weiterleitung zur Startseite



Forensoftware: Burning Board 2.3.6, entwickelt von WoltLab GmbH