Linux - Grub: Parameter in der Commando-Zeile zurücksetzen?

  • Hallo,


    ich habe gerade eine kleineres Problem mit meinem Grub loader.
    Beim Dell XPS12 gibt es aktuell das Problem, dass die Hintergrundbeleuchtung sich beim Booten abschaltet (lässt sich dann aber wieder einschalten).
    Angeblich sollte der Zusatz acpi_backlight=vendor in der etc/default/grub das Problem lösen.
    Nun bleibt die Beleuchtung zwar an, aber ich erhalte den Fehler
    'The disk drive for /dev/mapper/cryptswap1 is not ready yet or not present. Continue to wait, or Press S to skip mounting or M for manual recovery'
    Ein Tastendruck bewirkt nichts...
    Nun würde ich gerne irgendwie wieder ohne den Parameter acpi... booten.
    Ich hoffe mal, das geht über die grub-command-line - nur komme ich damit noch nicht ganz so klar.
    Hat wer einen Tipp?
    Zur Not habe ich auch noch ein Image ;D


    Vielen Dank im Voraus
    Gruß
    LJ

  • du startest nen rescue Linux.
    chrootest in das richtige und änderst die zeile wieder.
    alternativ machst du einfach nur mit ner "rescue"-CD nochmal nen update grup nachdem du den parameter gelöscht hast.


    Sinnvoller für das nächste mal...trag es direkt bei den kernelparametern mit ein. Diese kannst du dann beim booten einfach löschen.

  • Danke für die schnelle Antwort!
    habe mal die Variante mit der Live-CD ausprobiert und stieß auf ein Problem mit UEFI.
    Nun habe ich mein Disk-Images zurück gespielt und alles läuft wieder - wollte das ja auch unbedingt mal testen;)


    Könntest du mir noch kurz beschreiben, wie das mit den Kernelparametern funktionieren würde?


    Vielen Dank
    Gruß
    LJ